码迷,mamicode.com
首页 > 其他好文 > 详细

回溯法——Red and Black

时间:2015-08-15 20:07:33      阅读:111      评论:0      收藏:0      [点我收藏+]

标签:c++   acm   cpp   数据   编程   

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.‘ - a black tile
‘#‘ - a red tile
‘@‘ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

 

代码

#include <iostream>
#include <cstring>
using namespace std;
int n,m,cnt;
char map[20][20];
bool vis[20][20];
int dfs(int a,int b)
{
    if(a<0||a>=n||b<0||b>=m||map[a][b]=='#'||vis[a][b])
        return 0;
    else
    {
        vis[a][b]=true;
        return 1+dfs(a-1,b)+dfs(a+1,b)+dfs(a,b-1)+dfs(a,b+1);
    }
}
int main()
{
    while(cin>>m>>n&&(m||n))
    {
        int a,b;
        for(int i=0; i<n; ++i)
        {
            for(int j=0; j<m; ++j)
            {
                cin>>map[i][j];
                if(map[i][j]=='@')
                {
                    a=i;
                    b=j;
                }
            }
        }
        memset(vis,false,sizeof(vis));
        cnt=dfs(a,b);
        cout<<cnt<<endl;
    }
    return 0;
}


做完支教就要做ACM,暑假还没好好玩,真的累了。。。。

 

版权声明:本文为博主原创文章,未经博主允许不得转载。

回溯法——Red and Black

标签:c++   acm   cpp   数据   编程   

原文地址:http://blog.csdn.net/blue_skyrim/article/details/47684181

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!