码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj 2473 Junk-Mail Filter【并查集节点的删除】

时间:2015-08-15 22:56:27      阅读:132      评论:0      收藏:0      [点我收藏+]

标签:

Junk-Mail Filter

Time Limit: 15000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7515    Accepted Submission(s): 2368


Problem Description
Recognizing junk mails is a tough task. The method used here consists of two steps:
1) Extract the common characteristics from the incoming email.
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so
relationships (other than the one between X and Y) need to be created if they are not present at the moment.

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.
Please help us keep track of any necessary information to solve our problem.
 

 

Input
There are multiple test cases in the input file.
Each test case starts with two integers, N and M (1 ≤ N ≤ 105 , 1 ≤ M ≤ 106), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.
 

 

Output
For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.
 

 

Sample Input
5 6
M 0 1
M 1 2
M 1 3
S 1
M 1 2
S 3
 
 
3 1
M 1 2
 
0 0
 

 

Sample Output
Case #1: 3
Case #2: 2
 
并查集的删除详解见:点我打开链接
#include<stdio.h>
#include<string.h>
#define MAX 1001000
int set[MAX],vis[MAX];
int mark[MAX];
int n,m,count;
void init()
{
	int i,j;
	for(i=0;i<n;i++)
	{
		set[i]=i;
		vis[i]=i;
	}
}
int find(int fa)
{
	int t;
	int ch=fa;
	while(fa!=set[fa])
	fa=set[fa];
	while(ch!=fa)
	{
		t=set[ch];
		set[ch]=fa;
		ch=t;
	} 
	return fa;
}
void mix(int x,int y)
{
	int fx,fy;
	fx=find(x);
	fy=find(y);
	if(fx!=fy)
		set[fx]=fy;
} 
void getmap()
{
	int i,j,k=n;
	char a[2];
	memset(a,‘\0‘,sizeof(a));
	for(i=0;i<m;i++)
	{
		scanf("%s",a);
		if(a[0]==‘M‘)
		{
			int b,c;
			scanf("%d%d",&b,&c);
			mix(vis[b],vis[c]);
		}
		else
		{
			int b;
			scanf("%d",&b);
			vis[b]=k;
			set[k]=k;
			k++;
		}
	}
}
void solve()
{
	int i,ans=0;
	memset(mark,0,sizeof(mark));
	for(i=0;i<n;i++)
	{
		int stem=find(vis[i]);
		if(!mark[stem])
		{
			ans++;
			mark[stem]=1;
		}
	}
	printf("Case #%d: %d\n",count++,ans);
}
int main()
{
	count=1;
    while(scanf("%d%d",&n,&m),n|m)
    {
    	init();
    	getmap();
    	solve();
    }
	return 0;
}

  

hdoj 2473 Junk-Mail Filter【并查集节点的删除】

标签:

原文地址:http://www.cnblogs.com/tonghao/p/4733216.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!