码迷,mamicode.com
首页 > 其他好文 > 详细

Light 1008

时间:2015-08-15 23:11:27      阅读:163      评论:0      收藏:0      [点我收藏+]

标签:

H -
Time Limit:500MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

Fibsieve had a fantabulous (yes, it‘s an actual word) birthday party this year. He had so many gifts that he was actually thinking of not having a party next year.

Among these gifts there was an N x N glass chessboard that had a light in each of its cells. When the board was turned on a distinct cell would light up every second, and then go dark.

The cells would light up in the sequence shown in the diagram. Each cell is marked with the second in which it would light up.

技术分享

(The numbers in the grids stand for the time when the corresponding cell lights up)

In the first second the light at cell (1, 1) would be on. And in the 5th second the cell (3, 1) would be on. Now, Fibsieve is trying to predict which cell will light up at a certain time (given in seconds). Assume that N is large enough.

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case will contain an integer S (1 ≤ S ≤ 1015) which stands for the time.

Output

For each case you have to print the case number and two numbers (x, y), the column and the row number.

Sample Input

3

8

20

25

Sample Output

Case 1: 2 3

Case 2: 5 4

Case 3: 1 5




#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define LL long long
using namespace std;
LL n,m;
int main()
{
    LL y,x,k,t,s,l,r;
    LL cla;
    scanf("%lld",&cla);
    for(int gr=1; gr<=cla; gr++)
    {
        scanf("%lld",&n);
        printf("Case %lld: ",gr);
        s=sqrt(n);
        if(s*s==n)
        {
            if(!(s%2) )
                printf("%lld 1\n",s);
            else
                printf("1 %lld\n",s);
        }
        else
        {
            k=s+1;
            x=k*k-n;
            if(k%2==0)
            {
                if(x<k)
                    printf("%lld %lld\n",k,x+1);
                else printf("%lld %lld\n",2*k-x-1,k);
            }
            else
            {
                if(x<k)
                printf("%lld %lld\n",x+1,k);
                else printf("%lld %lld\n",k,2*k-1-x);
            }
        }
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

Light 1008

标签:

原文地址:http://blog.csdn.net/grit_icpc/article/details/47685735

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!