码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2155 Matrix

时间:2015-08-16 10:53:27      阅读:107      评论:0      收藏:0      [点我收藏+]

标签:

http://poj.org/problem?id=2155


Description
Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using “not” operation (if it is a ‘0’ then change it into ‘1’ otherwise change it into ‘0’). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

  1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
  2. Q x y (1 <= x, y <= n) querys A[x, y].

Input
The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format “Q x y” or “C x1 y1 x2 y2”, which has been described above.

Output
For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

这是一题简单的二维树状数组。

#include<iostream>
 #include<cstdio>
 #include<cstring>
 #include<algorithm>
 #include<cmath>
 using namespace std;
 const int maxn=1005;
 int va[maxn][maxn];
 int n,m;
 int lowbit(int x)
 {
     return x&(-x);
 }
 void update(int x,int y)
 {
    for(int i=x;i<=n;i+=lowbit(i))
        for(int j=y;j<=n;j+=lowbit(j))
           va[i][j] +=1;
 }
 int Sum(int x,int y)
 {
    int ans=0;
    for(int i=x;i>0;i-=lowbit(i))
        for(int j=y;j>0;j-=lowbit(j))
          ans+=va[i][j];
    return ans;
 }
 int main()
 {
     int N;
     int x1,y1,x2,y2;
     char op[10];
     scanf("%d",&N);
     while(N--)
     {
        memset(va,0,sizeof(va));
        scanf("%d %d",&n,&m);
        while(m--)
        {
            scanf("%S",op);
            if(op[0]=='C')
            {
                scanf("%d %d %d %d",&x1,&y1,&x2,&y2);
                update(x1,y1);
                update(x1,y2+1);
                update(x2+1,y1);
                update(x2+1,y2+1);
            }
            else
            {
                scanf("%d %d",&x1,&y1);
                printf("%d\n",Sum(x1,y1)%2);
            }
        }
        printf("\n");
     }
     return 0;
 }



版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ 2155 Matrix

标签:

原文地址:http://blog.csdn.net/hellohelloc/article/details/47699699

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!