码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1008 Elevator

时间:2015-08-16 10:55:06      阅读:118      评论:0      收藏:0      [点我收藏+]

标签:

http://acm.hdu.edu.cn/showproblem.php?pid=1008


Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 52650    Accepted Submission(s): 29078


Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 

Output
Print the total time on a single line for each test case.
 

Sample Input
1 2 3 2 3 1 0
 

Sample Output
17 41
 

题意:电梯上一层要花6s,下一层楼要花四秒,没听一次要花五秒,请问电梯在整个过程所用的总时间。

解题思路:1)每层楼停5s,上一层楼要6s,下一层楼要4s。
2)这里有个注意点是对于最后一个到达点,也是要停5s的,所以最后应该是加上n * 5,而不是(n - 1) * 5。
3)刚开始是从0层开始的,最后不必回到0层。

复杂度分析: 时间复杂度:o(n)
空间复杂度:o(n)

#include<iostream>
  using namespace std;
  int main()
  {
      int n,i,sum,tap;
      int a[101];
      while(cin >> n && n)
      {
          sum=0;
          tap=0;
          for(i=0;i<n;i++) cin >> a[i];
          for(i=0;i<n;i++)
          {
              if(tap<a[i]) sum = sum+6*(a[i]-tap)+5;
              else if(tap>a[i]) sum = sum+4*(tap-a[i])+5;
              else sum +=5;
              tap=a[i];
          }
          cout << sum << endl;
      }
      return 0;
  }



版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 1008 Elevator

标签:

原文地址:http://blog.csdn.net/hellohelloc/article/details/47699667

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!