码迷,mamicode.com
首页 > 其他好文 > 详细

uva_10048_Audiophobia(floyd)

时间:2015-08-16 15:15:29      阅读:174      评论:0      收藏:0      [点我收藏+]

标签:acm   algorithm   uva   graph   floyd   

Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

Status

Description


Consider yourself lucky! Consider yourself lucky to be still breathing and having fun participating in this contest. But we apprehend that many of your descendants may not have this luxury. For, as you know, we are the dwellers of one of the most polluted cities on earth. Pollution is everywhere, both in the environment and in society and our lack of consciousness is simply aggravating the situation.
However, for the time being, we will consider only one type of pollution - the sound pollution. The loudness or intensity level of sound is usually measured in decibels and sound having intensity level 130 decibels or higher is considered painful. The intensity level of normal conversation is 6065 decibels and that of heavy traffic is 7080 decibels.
Consider the following city map where the edges refer to streets and the nodes refer to crossings. The integer on each edge is the average intensity level of sound (in decibels) in the corresponding street.

技术分享

To get from crossing A to crossing G you may follow the following path: A->C->F->G. In that case you must be capable of tolerating sound intensity as high as 140 decibels. For the paths A->B->E->G,A->B->D->G and A->C->F->D->G you must tolerate respectively 90, 120 and 80 decibels of sound intensity. There are other paths, too. However, it is clear that A->C->F->D->G is the most comfortable path since it does not demand you to tolerate more than 80 decibels.
In this problem, given a city map you are required to determine the minimum sound intensity level you must be able to tolerate in order to get from a given crossing to another.


Input


The input may contain multiple test cases.
The first line of each test case contains three integers C(<=100),S(<=1000),Q(<=10000) where C indicates the number of crossings (crossings are numbered using distinct integers ranging from 1 to C),S represents the number of streets and Q is the number of queries.
Each of the next S lines contains three integers:c1,c2 and d indicating that the average sound intensity level on the street connecting the crossings c1 and c2(c1 != c2) is d decibels.
Each of the next Q lines contains two integers c1 and c2(c1 != c2) asking for the minimum sound intensity level you must be able to tolerate in order to get from crossing c1 to crossing c2.
The input will terminate with three zeros form C,S and Q.

Output

For each test case in the input rst output the test case number (starting from 1) as shown in the sample output. Then for each query in the input print a line giving the minimum sound intensity level (in decibels) you must be able to tolerate in order to get from the rst to the second crossing in the query. If there exists no path between them just print the line "no path".
Print a blank line between two consecutive test cases.

Sample Input
7 9 3
1 2 50
1 3 60
2 4 120
2 5 90
3 6 50
4 6 80
4 7 70
5 7 40
6 7 140
1 7
2 6
6 2
7 6 3
1 2 50
1 3 60
2 4 120
3 6 50
4 6 80
5 7 40
7 5
1 7
2 4
0 0 0
Sample Output
Case #1
80
60
60
Case #2
40
no path
80

题意:输入一个C个点S条边(C<=100,s<=1000)的无向带权图,边权表示该路径上的噪音值。当噪音太大时,耳膜可能会受到伤害,所以当你从某点去往另一个点时,总是希望经过的最大噪音值最小。输入一些询问,每次询问两个点,输出这两点间最大噪音值最小的值。

分析:floyd算法求路径上最大权值边的最小值。dp[i][j]=min(dp[i][j],max(dp[i][k],dp[k][j]))。

题目链接:http://acm.hust.edu.cn/vjudge/problem/viewProblem.action?id=22156

代码清单:

#include<set>
#include<map>
#include<cmath>
#include<queue>
#include<stack>
#include<ctime>
#include<cctype>
#include<string>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

typedef long long ll;
typedef unsigned int uint;
typedef unsigned long long ull;

const int maxn = 100 + 5;
const int max_dis = 1e9 + 5;

int c,s,q;
int u,v,dis;
int dp[maxn][maxn];
int cases;

void init(){
    for(int i=0;i<maxn;i++){
        for(int j=0;j<maxn;j++){
            if(i==j) dp[i][j]=0;
            else dp[i][j]=max_dis;
        }
    }
}

void input(){
    for(int i=1;i<=s;i++){
        scanf("%d%d%d",&u,&v,&dis);
        dp[u][v]=dp[v][u]=min(dp[u][v],dis);
    }
}

void floyd(){
    for(int k=1;k<=c;k++){
        for(int i=1;i<=c;i++){
            for(int j=1;j<=c;j++){
                dp[i][j]=min(dp[i][j],max(dp[i][k],dp[k][j]));
            }
        }
    }
}

void solve(){
    floyd();
    if(cases) printf("\n");
    printf("Case #%d\n",++cases);
    for(int i=1;i<=q;i++){
        scanf("%d%d",&u,&v);
        if(dp[u][v]==max_dis)
            printf("no path\n");
        else printf("%d\n",dp[u][v]);
    }
}

int main(){
    cases = 0;
    while(scanf("%d%d%d",&c,&s,&q)!=EOF){
        if(!c&&!s&&!q) break;
        init();
        input();
        solve();
    }return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

uva_10048_Audiophobia(floyd)

标签:acm   algorithm   uva   graph   floyd   

原文地址:http://blog.csdn.net/jhgkjhg_ugtdk77/article/details/47702161

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!