码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3268 Silver Cow Party(dijkstra+矩阵转置)

时间:2015-08-16 15:17:12      阅读:142      评论:0      收藏:0      [点我收藏+]

标签:acm   算法   dijkstra   

Silver Cow Party
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 15460   Accepted: 7004

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow‘s return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: NM, and X 
Lines 2..M+1: Line i+1 describes road i with three space-separated integers: AiBi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

题目大意:

n头牛要到达某一个点X,然后再返回到原来的位置。同时要求对于每头牛路径必须是最短的,而且去的路和回来的路不一样。求这些牛所花费的最长时间。

解题思路:
首先返回的路很好求,以X为起点求到达各个点的最短路。然后我们只需要求出到达X的最短路。
在别人那里知道了矩阵转置这个东西,其实要求到达X的最短路,我们只需要把每个边权值不变,方向调转,那么我们再按照求从X出发的单源最短路的方法,就可以求出到达X的最短路了。最后循环一遍求出到达和返回的和的最大值。


参考代码:

#include<stack>
#include<queue>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const double eps=1e-10;
const int INF=0x3f3f3f3f;
const int MAXN=1100;

int n,m,p,edge[MAXN][MAXN],backedge[MAXN][MAXN],mincost1[MAXN],mincost2[MAXN];
bool used1[MAXN],used2[MAXN];

void dijkstra(int start)
{
    for(int i=1; i<=n; i++)
    {
        used1[i]=used2[i]=false;
        mincost1[i]=edge[start][i];
        mincost2[i]=edge[i][start];
    }
    used1[start]=used2[start]=true;
    int v;
    while(true)
    {
        v=-1;
        for(int i=1; i<=n; i++)
            if(!used1[i]&&(v==-1||mincost1[i]<mincost1[v]))
                v=i;
        if(v==-1)
            break;
        used1[v]=true;
        for(int i=1; i<=n; i++)
            if(!used1[i]&&mincost1[i]>mincost1[v]+edge[v][i])
                mincost1[i]=mincost1[v]+edge[v][i];

        v=-1;
        for(int i=1; i<=n; i++)
            if(!used2[i]&&(v==-1||mincost2[i]<mincost2[v]))
                v=i;
        if(v==-1)
            break;
        used2[v]=true;
        for(int i=1; i<=n; i++)
            if(!used2[i]&&mincost2[i]>mincost2[v]+backedge[v][i])
                mincost2[i]=mincost2[v]+backedge[v][i];
    }
}

int main()
{
#ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
#endif // ONLINE_JUDGE
    while(scanf("%d%d%d",&n,&m,&p)!=EOF)
    {
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                if(i==j)
                    edge[i][j]=backedge[i][j]=0;//方向相反
                else
                    edge[i][j]=backedge[i][j]=INF;
        for(int i=1; i<=m; i++)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            edge[b][a]=backedge[a][b]=c;
        }
        dijkstra(p);
        int ans=-1;
        for(int i=1; i<=n; i++)
            ans=max(ans,mincost1[i]+mincost2[i]);
        printf("%d\n",ans);
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ 3268 Silver Cow Party(dijkstra+矩阵转置)

标签:acm   算法   dijkstra   

原文地址:http://blog.csdn.net/noooooorth/article/details/47702069

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!