码迷,mamicode.com
首页 > 其他好文 > 详细

UVa 1584 - Circular Sequence

时间:2015-08-16 18:27:35      阅读:137      评论:0      收藏:0      [点我收藏+]

标签:uva   as   

https://uva.onlinejudge.org/external/15/1584.pdf

Some DNA sequences exist in circular forms as in the following figure, which shows a circular sequence
CGAGTCAGCT", that is, the last symbol“T” in CGAGTCAGCT" is connected to the first symbol”C”.
We always read a circular sequence in the clockwise direction.
Since it is not easy to store a circular sequence in a computer as it is, we decided to store it as a linear
sequence. However, there can be many linear sequences that are obtained from a circular sequence by cutting
any place of the circular sequence. Hence, we also decided to store the linear sequence that is
lexicographically smallest among all linear sequences that can be obtained from a circular sequence.
Your task is to find the lexicographically smallest sequence from a given circular sequence. For the example
in the figure, the lexicographically smallest sequence is “AGCTCGAGTC”. If there are two or more linear
sequences that are lexicographically smallest, you are to find any one of them (in fact, they are the same).
Input
The input consists of T test cases. The number of test cases T is given on the first line of the input file. Each
test case takes one line containing a circular sequence that is written as an arbitrary linear sequence. Since the
circular sequences are DNA sequences, only four symbols, A, C, G and T, are allowed. Each sequence has
length at least 2 and at most 100.
Output
Print exactly one line for each test case. The line is to contain the lexicographically smallest sequence for the
test case.
The following shows sample input and output for two test cases.
Sample Input
2
CGAGTCAGCT
CTCC
Sample Output
AGCTCGAGTC
CCCT

分析:
给你一个串,这个串是一个环,你需要找到这个环中字典序最小的串,并输出即可

#include <iostream>
#include <sstream>
#include <iomanip>
#include <vector>
#include <deque>
#include <list>
#include <set>
#include <map>
#include <stack>
#include <queue>
#include <bitset>
#include <string>
#include <numeric>
#include <algorithm>
#include <functional>
#include <iterator>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <complex>
#include <ctime>
#define INF 0x3f3f3f3f
#define eps 1e-6
#define p(x) printf("%d\n", x)
#define k(x) printf("Case %d: ", ++x)
#define mes(x, d) memset(x, d, sizeof(x))
#define s(x) scanf("%d", &x)


typedef long long LL;

const double pi = acos(-1.0);
const long long mod = 1e9 + 7;


using namespace std;

char s[105];

int Less(const char * s,int p,int q)
{
    int len = strlen(s);
    for(int i = 0;i < len;i++)
        if(s[(i + p) % len] != s[(i + q) % len])
            return s[(p + i) % len] < s[(i + q) % len];
    return 0;
}

int main()
{
    //freopen("int.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int T,N;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s",s);
        int ans = 0;
        int len = strlen(s);
        for(int i = 0;i < len;i++)
        {
            if(Less(s,i,ans))
                ans = i;

        }
        for(int i = 0;i < len;i++)
            putchar(s[(i + ans) % len]);
        puts("");
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

UVa 1584 - Circular Sequence

标签:uva   as   

原文地址:http://blog.csdn.net/qq_28236309/article/details/47703345

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!