码迷,mamicode.com
首页 > 其他好文 > 详细

NYOJ--364--田忌赛马

时间:2015-08-16 19:56:12      阅读:103      评论:0      收藏:0      [点我收藏+]

标签:算法 贪心 nyoj

田忌赛马

时间限制:3000 ms  |  内存限制:65535 KB
难度:3
描述
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian‘s. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king‘s regular, and his super beat the king‘s plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian‘s horses on one side, and the king‘s horses on the other. Whenever one of Tian‘s horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
输入
The input consists of many test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses.
输出
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

样例输入
3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
样例输出
200
0
0

题意:就是田忌赛马的故事,不过这次比赛的马不再是3只了,而变成了很多只,如果田忌输了就要给别人200块,赢了就拿200块,平局就算了。问田忌最多能拿多少钱。

思路:考虑这道题的话,就是一道标准的贪心,如何实现呢? 我们这样考虑;

1、我们先比较能力最大的,如果T(田忌)的马能力强,那就继续从强的这边比较。

2、不然就开始比较弱马,如果T弱马能力更弱或者等于K的弱马,就让这只马和K的强马比赛,田忌故意输一局。

AC代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
int win,los,t[1010],k[1010];
int n;
void cmp(){
	win=0;
	los=0;
	int l1=0,l2=0,r1=n-1,r2=n-1;
	while(l1!=r1+1){//如果直接在l1==r1的时候就跳出了循环,就会少比较一个。 
		if(t[r1]>k[r2]){
			win++;
			r1--;
			r2--;
			continue;//加这个是让他一次只比较一个。也可以让他一直比较然后在左右两侧相等时跳出。 
		}
		if(t[r1]<=k[r2]){
			if(t[l1]>k[l2]){
				win++;
				l1++;
				l2++;
				continue;//与上面的同理。 
			}
			if(t[l1]<=k[l2]){
				if(t[l1]<k[r2])
					los++;
				if(t[l1]>k[r2])
					win++;
				l1++;
				r2--;
			}
		}
	}
}
int main(){
	
	while(scanf("%d",&n)!=EOF){
		int i;
		for(i=0;i<n;i++)
			scanf("%d",&t[i]);
		for(i=0;i<n;i++)
			scanf("%d",&k[i]); 
		sort(t,t+n);
		sort(k,k+n);
		cmp();
		int ans=(win-los)*200;
		printf("%d\n",ans); 
	}
	
	return 0;
} 


版权声明:本文为博主原创文章,未经博主允许不得转载。

NYOJ--364--田忌赛马

标签:算法 贪心 nyoj

原文地址:http://blog.csdn.net/gui951753/article/details/47704211

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!