标签:acm算法
Problem Description
Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:
The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.
The players take turns chosing a heap and removing a positive number of beads from it.
The first player not able to make a move, loses.
Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:
Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).
If the xor-sum is 0, too bad, you will lose.
Otherwise, move such that the xor-sum becomes 0. This is always possible.
It is quite easy to convince oneself that this works. Consider these facts:
The player that takes the last bead wins.
After the winning player‘s last move the xor-sum will be 0.
The xor-sum will change after every move.
Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win.
Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove
a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?
your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position.
This means, as expected, that a position with no legal moves is a losing position.
Input
Input consists of a number of test cases. For each test case: The first line contains a number k (0 < k ≤ 100 describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0
< m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. The last test case is followed by
a 0 on a line of its own.
Output
For each position: If the described position is a winning position print a ‘W‘.If the described position is a losing position print an ‘L‘. Print a newline after each test case.
Sample Input
2 2 5
3
2 5 12
3 2 4 7
4 2 3 7 12
5 1 2 3 4 5
3
2 5 12
3 2 4 7
4 2 3 7 12
0
Sample Output
Source
Recommend
LL | We have carefully selected several similar problems for you:
1404 1517 1524 1729 1079
题意:给一个n,n个数。下面博弈的时候取数只能从这n个数里面取。
下面m行,每行开头是石头的堆数,后面的数字代表每堆石头的个数。然后开始博弈,先手胜的话,输出W,否则输出L。
用序列构造sg函数。然后博弈即可。
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <iostream>
#include <cstdio>
using namespace std;
int sg[10005];
int f[110];
void getsg(int n)
{
int i,j;
memset(sg,0,sizeof(sg));
bool hash1[10005]; //一定要用bool 定义,不然会超时。
for(i=0; i<10005; i++)
{
memset(hash1,0,sizeof(hash1));
for(j=0; j<n; j++)
{
if(i-f[j]>=0)
hash1[sg[i-f[j]]]=1;
}
for(j=0; j<10005; j++)
{
if(!hash1[j])
{
sg[i]=j;
break;
}
}
}
return ;
}
int main()
{
int n;
while(scanf("%d",&n)!=EOF&&n!=0)
{
for(int i=0; i<n; i++)
scanf("%d",&f[i]);
sort(f,f+n);
getsg(n);
int m;
// for(int i=0; i<1000; i++)
// cout<<sg[i]<<" ";
scanf("%d",&m);
for(int i=0; i<m; i++)
{
int t;
int pp;
int res=0;
scanf("%d",&t);
for(int j=0; j<t; j++)
{
scanf("%d",&pp);
res=res^sg[pp];
}
if(res==0)
printf("L");
else
printf("W");
}
printf("\n");
}
return 0;
}
版权声明:本文为博主原创文章,未经博主允许不得转载。
HDU 1536(sg博弈) S-Nim
标签:acm算法
原文地址:http://blog.csdn.net/sky_miange/article/details/47705633