码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 3342 Legal or Not

时间:2015-08-17 12:08:31      阅读:130      评论:0      收藏:0      [点我收藏+]

标签:

Legal or Not

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6069    Accepted Submission(s): 2818


Problem Description
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it‘s legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian‘s master and, at the same time, 3xian is HH‘s master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. 

Please note that the "master and prentice" relation is transitive. It means that if A is B‘s master ans B is C‘s master, then A is C‘s master.
 

Input
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y‘s master and y is x‘s prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
 

Output
For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".
 

Sample Input
3 2 0 1 1 2 2 2 0 1 1 0 0 0
 

Sample Output
YES NO
 

Author
QiuQiu@NJFU
 

Source

意思很简单,就是问给出的图是否能进行拓扑排序,能则输出“YES”,否则输出“NO”。
//Accepted
//  31MS	1660K

//HDU3342(拓扑排序模版)

#include<cstdio>
#include<cstring>
const int N = 120;
int map[N][N],indegree[N];
int Topo(int n) {
    for(int i=0; i<n; i++) {
        int  ans=n;
        for(int j=0; j<n; j++) {
            if(indegree[j]==0) {    //找到入度为0 的点
                indegree[j]--;
                ans=j;
                break;
            }
        }
        if(ans==n)  //ans没有更新说明已经没有入度为0的结点了,即无法进行拓扑排序直接返回0
            return 0;
        for(int j=0; j<n; j++)
            if(map[ans][j]>0)  //与上面选出来入度为0结点相连的点的入度 减 1
                indegree[j]--;
    }
    return 1;
}
int main() {
    int m,n,p,q,flag;
    while(~scanf("%d%d",&n,&m) && n && m) {
        memset(map,0,sizeof(map));
        memset(indegree,0,sizeof(indegree));
        for(int i=0; i<m; i++) {
            scanf("%d%d",&p,&q);
            if(map[p][q]==0) { //在这儿必须判断,否则会影响入度的值
                map[p][q]=1;
                indegree[q]++;
            }
        }
        flag=Topo(n);
        printf("%s\n",flag?"YES":"NO");
    }
    return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 3342 Legal or Not

标签:

原文地址:http://blog.csdn.net/zhang_xueping/article/details/47721371

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!