码迷,mamicode.com
首页 > 其他好文 > 详细

HDU-5391 Zball in Tina Town

时间:2015-08-17 15:27:10      阅读:171      评论:0      收藏:0      [点我收藏+]

标签:

(n-1)!/n 就是如果n为素数,就等于n-1else为0。

求素数表:

 

Zball in Tina Town

Time Limit: 3000/1500 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 833 Accepted Submission(s): 477


Problem Description
Tina Town is a friendly place. People there care about each other.

Tina has a ball called zball. Zball is magic. It grows larger every day. On the first day, it becomes 1技术分享 time as large as its original size. On the second day,it will become 2技术分享 times as large as the size on the first day. On the n-th day,it will become n技术分享 times as large as the size on the (n-1)-th day. Tina want to know its size on the (n-1)-th day modulo n.
 

 

Input
The first line of input contains an integer T技术分享 , representing the number of cases.

The following T技术分享 lines, each line contains an integer n技术分享 , according to the description.
T10技术分享5技术分享,2n10技术分享9技术分享技术分享
 

 

Output
For each test case, output an integer representing the answer.
 

 

Sample Input
2 3 10
 

 

Sample Output
2 0
 

 

Source
#include<iostream>
#include <cstdio>
#include<cstring>
using namespace std;
bool is_prime(int n)
{
    for(int i=2;i*i<=n;i++){
         if(n%i==0) return false;
    }
    return n!=1;
}
int main (void)
{
int n,t;
scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        if(n==4)
      {
       printf("2\n");
       continue;
       }
        if(is_prime(n))
              printf("%d\n",n-1);
        else
           printf("0\n");

    }
    return 0;
}

 

 

HDU-5391 Zball in Tina Town

标签:

原文地址:http://www.cnblogs.com/cancangood/p/4736551.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!