码迷,mamicode.com
首页 > 其他好文 > 详细

杭电(hdu)5019 Revenge of GCD

时间:2015-08-17 15:41:29      阅读:128      评论:0      收藏:0      [点我收藏+]

标签:acm   gcd   杭电   

Revenge of GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1724    Accepted Submission(s): 472


Problem Description
In mathematics, the greatest common divisor (gcd), also known as the greatest common factor (gcf), highest common factor (hcf), or greatest common measure (gcm), of two or more integers (when at least one of them is not zero), is the largest positive integer that divides the numbers without a remainder.
---Wikipedia

Today, GCD takes revenge on you. You have to figure out the k-th GCD of X and Y.
 

Input
The first line contains a single integer T, indicating the number of test cases. 

Each test case only contains three integers X, Y and K.

[Technical Specification]
1. 1 <= T <= 100
2. 1 <= X, Y, K <= 1 000 000 000 000
 

Output
For each test case, output the k-th GCD of X and Y. If no such integer exists, output -1.
 

Sample Input
3 2 3 1 2 3 2 8 16 3
 

Sample Output
1 -1 2
 
本题大意:求出俩数的第k大的约数。
本题思想:我做这题的思想是先求出本题的最大公约数,再求出最大公约数所有的因子,用STL中set容器存储。使用反向迭代器,可求出第k大的因子。
代码如下:
#include <iostream>
#include <string>
#include <cmath>
#include <cstring>
#include <set>
typedef __int64 ll;
using namespace std;

set<ll> s;
ll GCD(ll xx,ll yy)
{
    ll r=1;
    while(r!=0)
    {
        r=xx%yy;
        xx=yy;
        yy=r;
    }
    return xx;
}

int main()
{
    int T;
    ll x,y,k,gcd,count;
    cin>>T;
    while(T--)
    {
        count=0;
        cin>>x>>y>>k;
        gcd=GCD(x,y);
        for(int i=1;i<=sqrt(gcd);i++)
        {
            if(gcd%i==0)
            {
                s.insert(i);
                s.insert(gcd/i);
            }
        }
        set<ll>::reverse_iterator rit;
        for(rit=s.rbegin();rit!=s.rend();rit++)
        {
            //cout<<*rit<<" ";
            count++;
            if(count==k)
            {
              cout<<*rit<<endl;
              break;
            }
        }
        if(count<k)cout<<"-1"<<endl;
        s.clear();
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。欢迎读者评论和指正

杭电(hdu)5019 Revenge of GCD

标签:acm   gcd   杭电   

原文地址:http://blog.csdn.net/it142546355/article/details/47724397

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!