码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2680:Choose the best route【Dijkstra】

时间:2015-08-17 17:20:33      阅读:129      评论:0      收藏:0      [点我收藏+]

标签:hdu   dijkstra   图论   最短路   

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10287    Accepted Submission(s): 3317


Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
1 -1
 


从起点往终点找要多次调用函数,很容易超时~所以需要反着来~~只调用一次函数~~而且还要注意的是。。。路径是单向的~~

AC-code:

#include<cstdio>
#define max 0x3f3f3f3f
#define min(a,b) (a>b?b:a)
int n,dis[1005],cost[1005][1005];
void dijkstra(int a)
{
	int vis[1005],i;
	for(i=1;i<=n;i++)
	{
		dis[i]=max;
		vis[i]=0;
	}
	dis[a]=0;
	while(1)
	{
		int v=-1;
		for(i=1;i<=n;i++)
			if(!vis[i]&&(dis[i]<dis[v]||v==-1))
				v=i;
		if(v==-1)
			break;
		vis[v]=1;
		for(i=1;i<=n;i++)
			dis[i]=min(dis[i],dis[v]+cost[v][i]);
	}
}
int main()
{
	int so[1005],m,s,i,j,a,b,c;
	while(~scanf("%d%d%d",&n,&m,&s))
	{
		int ans=max;
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				cost[i][j]=max;
		while(m--)
		{
			scanf("%d%d%d",&a,&b,&c);
			cost[b][a]=min(cost[b][a],c);
		}
		scanf("%d",&a);
		dijkstra(s);
		for(i=0;i<a;i++)
		{
			scanf("%d",&b);
			ans=min(ans,dis[b]);
		}
		if(ans==max)
			printf("-1\n");
		else
			printf("%d\n",ans);
	}
	return 0;
}


 

版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 2680:Choose the best route【Dijkstra】

标签:hdu   dijkstra   图论   最短路   

原文地址:http://blog.csdn.net/lin14543/article/details/47727285

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!