码迷,mamicode.com
首页 > 其他好文 > 详细

hdu5305 Friends

时间:2015-08-17 19:34:53      阅读:114      评论:0      收藏:0      [点我收藏+]

标签:hdu   多校   搜索   

Problem Description
There are n people and m pairs of friends. For every pair of friends, they can choose to become online friends (communicating using online applications) or offline friends (mostly using face-to-face communication). However, everyone in these n people wants to have the same number of online and offline friends (i.e. If one person has x onine friends, he or she must have x offline friends too, but different people can have different number of online or offline friends). Please determine how many ways there are to satisfy their requirements. 
 

Input
The first line of the input is a single integer T (T=100), indicating the number of testcases. 

For each testcase, the first line contains two integers n (1n8) and m (0mn(n?1)2), indicating the number of people and the number of pairs of friends, respectively. Each of the next m lines contains two numbers x and y, which mean x and y are friends. It is guaranteed that xy and every friend relationship will appear at most once. 
 

Output
For each testcase, print one number indicating the answer.
 

Sample Input
2 3 3 1 2 2 3 3 1 4 4 1 2 2 3 3 4 4 1
 

Sample Output
0

2

这题是一道简单搜索题,我用dfs(idx,num1,num2)表示当前搜索的是idx的关系,num1表示虚拟关系的个数,num2表示现实关系的个数。

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<string>
#include<algorithm>
using namespace std;
#define maxn 100060
#define ll long long
int num[10],gra[10][10],n,m,sum,guanxi[10][10],vis1[10],vis2[10];

void dfs(int idx,int num1,int num2,int pos,int from)
{
    int i,j;
    if(num1==num2 && num1+num2==num[idx]){
        if(idx==n){
            sum++;return;
        }
        else{
            idx++;num1=num2=0;
            for(i=1;i<=n;i++){
               if(guanxi[idx][i]==1){
                   num2++;
               }
               else if(guanxi[idx][i]==0){
                   num1++;
               }
            }
            dfs(idx,num1,num2,idx+1,0);
        }
        return ;
    }

    if(num1>num[idx]/2 || num2>num[idx]/2)return;
    for(i=pos;i<=n;i++){
        if(gra[i][idx] && guanxi[i][idx]==-1){
            guanxi[i][idx]=guanxi[idx][i]=0;
            dfs(idx,num1+1,num2,i+1,1);
            guanxi[i][idx]=guanxi[idx][i]=1;
            dfs(idx,num1,num2+1,i+1,2);
            guanxi[i][idx]=guanxi[idx][i]=-1;break;
        }
    }
    return;
}

int main()
{
        int i,j,T,c,d,flag;
        scanf("%d",&T);
        while(T--)
        {
            scanf("%d%d",&n,&m);
            if(n==1){
                printf("1\n");continue;
            }
            memset(num,0,sizeof(num));
            memset(gra,0,sizeof(gra));
            for(i=1;i<=m;i++){
                scanf("%d%d",&c,&d);
                gra[c][d]=gra[d][c]=1;num[c]++;num[d]++;
            }
            flag=1;
            for(i=1;i<=n;i++){
                if(num[i]&1){
                    flag=0;break;
                }
            }
            if(!flag){
                printf("0\n");continue;
            }
            sum=0;
            memset(guanxi,-1,sizeof(guanxi));
            dfs(1,0,0,2,0);
            printf("%d\n",sum);
        }
        return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu5305 Friends

标签:hdu   多校   搜索   

原文地址:http://blog.csdn.net/kirito_acmer/article/details/47729507

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!