码迷,mamicode.com
首页 > 其他好文 > 详细

[POJ3070] Fibonacci|矩阵乘法

时间:2015-08-17 21:17:51      阅读:151      评论:0      收藏:0      [点我收藏+]

标签:

Fibonacci
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11024   Accepted: 7846

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

技术分享.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

技术分享.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

技术分享.

Source

 
第一次写矩阵快速幂……留着当模板吧。
#include<iostream>
#include<cstdio>
using namespace std;
int n,a[2][2],b[2][2];
void mul(int a[2][2],int b[2][2],int ans[2][2])
{
    int t[2][2];
    for (int i=0;i<=1;i++)    
        for (int j=0;j<=1;j++)
        {
            t[i][j]=0;
            for (int k=0;k<=1;k++)
                t[i][j]=(t[i][j]+a[i][k]*b[k][j])%10000;
        }
    for (int i=0;i<=1;i++)
        for (int j=0;j<=1;j++)
            ans[i][j]=t[i][j];
}
int main()
{
    while (scanf("%d",&n))
    {
        if (n==-1) return 0;
        a[0][0]=a[0][1]=a[1][0]=1; a[1][1]=0;
        b[0][0]=b[1][1]=1; b[0][1]=b[1][0]=0;
        while (n)
        {
            if (n&1) mul(a,b,b);
            n>>=1;
            mul(a,a,a);
        }
        printf("%d\n",b[1][0]);
    }
}

 

[POJ3070] Fibonacci|矩阵乘法

标签:

原文地址:http://www.cnblogs.com/ws-fqk/p/4737476.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!