码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2155 二维树状数组

时间:2014-07-12 15:09:54      阅读:201      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   strong   

http://poj.org/problem?id=2155

Matrix
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 17721   Accepted: 6653

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a ‘0‘ then change it into ‘1‘ otherwise change it into ‘0‘). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0



//////////////////////////////////////////////
二维树状数组题,挺难理解的,楼教主的经典题啊,还是要慢慢才能理解
参考下这个链接:http://blog.csdn.net/zxy_snow/article/details/6264135

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#define Maxx 1005

int n,m;
int c[Maxx][Maxx];

int Lowbit(int x)
{
    return x&(-x);
}

void Update(int x,int y,int i)
{
    int y1;
    while(x<=n)
    {
        y1=y;
        while(y1<=n)
        {
            c[x][y1]+=i;
            y1+=Lowbit(y1);
           }
        x+=Lowbit(x);
     }
}

int GetSum(int x,int y)
{
    int s=0;
    while(x>0)
        {
        int y1=y;
            while(y1>0)
                {
                    s+=c[x][y1];
                    y1-=Lowbit(y1);
                }
            x-=Lowbit(x);
        }
    return s;
}

int main()
{
    int i,j,t;
    char cas;
    int x1,y1,x,y,a,b;
    scanf("%d",&t);
    while(t--)
        {
            memset(c,0,sizeof(c));
            scanf("%d%d%*c",&n,&m);
            while(m--)
                {
                    scanf("%c",&cas);
                    if(cas == C)
                        {
                            scanf("%d%d%d%d%*c",&x,&y,&x1,&y1);
                            x++;y++;x1++;y1++;
                            Update(x1,y1,1);
                            Update(x-1,y1,1);
                            Update(x1,y-1,1);
                            Update(x-1,y-1,1);

                        }
                    else
                        {
                            scanf("%d%d%*c",&a,&b);
                            printf("%d\n",GetSum(a,b)%2);
                        }
                }
            printf("\n");
        }
    return 0;
}

 

poj 2155 二维树状数组,布布扣,bubuko.com

poj 2155 二维树状数组

标签:des   style   blog   http   color   strong   

原文地址:http://www.cnblogs.com/ccccnzb/p/3839741.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!