码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2155 Matrix

时间:2015-08-18 10:21:48      阅读:179      评论:0      收藏:0      [点我收藏+]

标签:poj   二维树状数组   

链接:http://poj.org/problem?id=2155


Matrix
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 21281   Accepted: 7954

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a ‘0‘ then change it into ‘1‘ otherwise change it into ‘0‘). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1


Sample Output

1
0
0
1


Source

POJ Monthly,Lou Tiancheng


大意——给你一个n*n矩阵,它的元素值是0或者1。一开始,我们把它们都置为0。那么接下来,我们可以用以下方式改变它们的值:给定两个数对(可以分别表示矩阵的行列下标),前一个在左上角,后一个在右下角,它们组成了一个矩形,将在矩形上以及内部的对应矩阵元素值翻转(1变为0,0变为1)。为了获取矩阵的信息,你能够对其进行两种操作,一种即为上面所述,另一种就是访问某一个元素的当前值。


思路——看完题目,知道这是一个更改区间值、访问单个值的问题。通过技巧转化一下,就不难想到是一个树状数组的题,因为是矩阵,所以是二维的树状数组。既然是要求翻转次数,那么我们先考虑一维的情形:假设要翻转区间[a,b],那么我们可以将树状数组节点a处翻转一次,节点b+1处再翻转一次,避免翻转了区间外面,那么判断节点c处翻转了多少次不就是树状数组的求和问题了吗?仔细想想吧!二维的也是类似的想法。


复杂度分析——时间复杂度:O(query*(log(n))^2),空间复杂度:O(n^2)


附上AC代码:


#include <iostream>
#include <cstdio>
#include <string>
#include <cmath>
#include <iomanip>
#include <ctime>
#include <climits>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>
#include <set>
#include <map>
//#pragma comment(linker, "/STACK:102400000, 102400000")
using namespace std;
typedef unsigned int li;
typedef long long ll;
typedef unsigned long long ull;
typedef long double ld;
const double pi = acos(-1.0);
const double e = exp(1.0);
const double eps = 1e-8;
const int maxn = 1005;
int mat[maxn][maxn];
char str[5]; // 键入命令
int n, query; // 矩阵的大小和问答个数大小

int lowbit(int x); // 求2^k,k是x为二进制时末尾的零个数
void update(int x, int y, int add); // 更新状态
int sum(int x, int y); // 求和

int main()
{
	ios::sync_with_stdio(false);
	int T;
	scanf("%d", &T);
	while (T--)
	{
		int x1, y1, x2, y2;
		memset(mat, 0, sizeof(mat)); // 开始将所有元素值置为0
		scanf("%d%d", &n, &query);
		while (query--)
		{
			scanf("%s%d%d", str, &x1, &y1);
			if (str[0] == 'C')
			{
				scanf("%d%d", &x2, &y2);
				update(x1, y1, 1); // 更新矩阵状态
				update(x1, y2+1, 1);
				update(x2+1, y1, 1);
				update(x2+1, y2+1, 1); // 上述三步是去掉重复部分
			}
			else
				printf("%d\n", sum(x1, y1)); // 计算总翻转次数,模2
		}
		printf("\n");
	}
	return 0;
}

int lowbit(int x)
{
	return (x&(-x));
}

void update(int x, int y, int add)
{
	for (int i=x; i!=0&&i<=n; i+=lowbit(i))
		for (int j=y; j!=0&&j<=n; j+=lowbit(j))
			mat[i][j] += add;
}

int sum(int x, int y)
{
	int res = 0;
	for (int i=x; i>0; i-=lowbit(i))
		for (int j=y; j>0; j-=lowbit(j))
			res += mat[i][j];
	return (res&1);
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ 2155 Matrix

标签:poj   二维树状数组   

原文地址:http://blog.csdn.net/silenceneo/article/details/47747193

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!