码迷,mamicode.com
首页 > 其他好文 > 详细

KMP练习——KMP模式匹配 一(串)

时间:2015-08-18 11:54:12      阅读:144      评论:0      收藏:0      [点我收藏+]

标签:c++   acm   c   cpp   kmp   

Description

求子串的next值,用next数组存放,全部输出

Input

输入一个字符串

Output

输出所有next值

Sample Input

abaabcac

Sample Output

0 1 1 2 2 3 1 2

 

代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
void getNext(char *p,int *next)
{
    int j=0,k=-1;
    next[0]=-1;
    while(j<strlen(p)-1)
    {
        if(k==-1||p[j]==p[k])
        {
            j++;
            k++;
            next[j]=k;
        }
        else
            k=next[k];
    }
}
int main()
{
	char a[100];
	int i,next[100];
	while(gets(a))
    {
        getNext(a,next);
        cout<<next[0]+1;
        for(i=1;a[i]!=0;++i)
            cout<<" "<<next[i]+1;
        cout<<endl;
    }
	return 0;
}


KMP算法中如何求NEXT函数,具体原理大家看看就好。。。。

 

 

版权声明:本文为博主原创文章,未经博主允许不得转载。

KMP练习——KMP模式匹配 一(串)

标签:c++   acm   c   cpp   kmp   

原文地址:http://blog.csdn.net/blue_skyrim/article/details/47749455

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!