码迷,mamicode.com
首页 > 其他好文 > 详细

Reverse Number

时间:2015-08-18 12:04:12      阅读:108      评论:0      收藏:0      [点我收藏+]

标签:

http://acm.hdu.edu.cn/showproblem.php?pid=1266

Reverse Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6187    Accepted Submission(s): 2816


Problem Description
Welcome to 2006‘4 computer college programming contest!

Specially, I give my best regards to all freshmen! You are the future of HDU ACM! And now, I must tell you that ACM problems are always not so easy, but, except this one... Ha-Ha!

Give you an integer; your task is to output its reverse number. Here, reverse number is defined as follows:
1. The reverse number of a positive integer ending without 0 is general reverse, for example, reverse (12) = 21;
2. The reverse number of a negative integer is negative, for example, reverse (-12) = -21;
3. The reverse number of an integer ending with 0 is described as example, reverse (1200) = 2100.
 

Input
Input file contains multiple test cases. There is a positive integer n (n<100) in the first line, which means the number of test cases, and then n 32-bit integers follow.
 

Output
For each test case, you should output its reverse number, one case per line.
 

Sample Input
3 12 -12 1200
 

Sample Output
21 -21 2100
 

Author
lcy
 

#include <cstdio>
#include <cstring>
void rev(char *ch1,char *ch2)
{
    while(*ch2=='0')ch2--;
    while(ch1<=ch2){
        char ch=*ch1;
        *ch1=*ch2;
        *ch2=ch;
        ch1++;
        ch2--;
    }
    return;
}
int main()
{
    int t;
    char ch[11];
    scanf("%d",&t);
    while (t--){
        scanf("%s",ch);
        int len=strlen(ch);
        if(ch[0]=='-')rev(ch+1,ch+len-1);
        else rev(ch,ch+len-1);
        printf("%s\n",ch);
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

Reverse Number

标签:

原文地址:http://blog.csdn.net/burning_newbie/article/details/47748251

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!