标签:
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7687 Accepted Submission(s): 4674
Problem Description
Eddy‘s interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can‘t write program, so Eddy has to ask intelligent you to help
him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .
Input
The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.
Output
You have to print a line in the output for each entry with the answer to the previous question.
Sample Input
Sample Output
#include<stdio.h>
int main()
{
int i,n;
while(scanf("%d",&n)!=EOF)
{
for(i=2;i<=n;i++)
{
while(n%i==0)
{
if(n/i==1)
printf("%d\n",i);
else printf("%d*",i);
n=n/i;
}
}
}
return 0;
}
版权声明:本文为博主原创文章,未经博主允许不得转载。
Eddy's research I
标签:
原文地址:http://blog.csdn.net/l15738519366/article/details/47752397