码迷,mamicode.com
首页 > 其他好文 > 详细

NBUT 1217 Dinner

时间:2015-08-18 16:33:02      阅读:140      评论:0      收藏:0      [点我收藏+]

标签:字符串

  • [1217] Dinner

  • 时间限制: 1000 ms 内存限制: 32768 K
  • 问题描述
  • Little A is one member of ACM team. He had just won the gold in World Final. To celebrate, he decided to invite all to have one meal. As bowl, knife and other tableware is not enough in the kitchen, Little A goes to take backup tableware in warehouse. There are many boxes in warehouse, one box contains only one thing, and each box is marked by the name of things inside it. For example, if "basketball" is written on the box, which means the box contains only basketball. With these marks, Little A wants to find out the tableware easily. So, the problem for you is to help him, find out all the tableware from all boxes in the warehouse.
  • 输入
  • There are many test cases. Each case contains one line, and one integer N at the first, N indicates that there are N boxes in the warehouse. Then N strings follow, each string is one name written on the box.
  • 输出
  • For each test of the input, output all the name of tableware.
  • 样例输入
  • 3 basketball fork chopsticks
    2 bowl letter
  • 样例输出
  • fork chopsticks
    bowl
  • 提示
  • The tableware only contains: bowl, knife, fork and chopsticks.
    
  • 来源
  • 辽宁省赛2010

    题目意思很简单,就是输入n个字符串,当遇到bowl, knife, fork ,chopsticks.这四个字符串时就输出。
    全部在一行输出,每两个中间用一个空格隔开,最后不能有空格(我原以为没关系,所以在这里PE了一次…这就是教训啊…)。。

    #include <algorithm>
    #include <iostream>
    #include <cstring>
    #include <cstdlib>
    #include <cstdio>
    #include <string>
    #include <vector>
    #include <cmath>
    #include <ctime>
    #include <queue>
    #include <stack>
    #include <set>
    #include <map>
    using namespace std;
    typedef long long LL;
    const int maxn= 100000 + 10;
    char str[maxn];
    char ss[4][20]= {"bowl","knife","fork","chopsticks"};
    int main() {
        int n;
        while(~scanf("%d",&n)) {
            bool flag=0;
            for(int i=0; i<n; i++) {
                scanf("%s",str);
                for(int j=0; j<4; j++)
                    if(strcmp(str,ss[j])==0) {
                        if(flag)
                            printf(" %s",ss[j]);
                        else
                        {
                            printf("%s",ss[j]);flag=1;
                        }
                        break;
                    }
            }
            puts("");
        }
        return 0;
    }


版权声明:本文为博主原创文章,未经博主允许不得转载。

NBUT 1217 Dinner

标签:字符串

原文地址:http://blog.csdn.net/zhang_xueping/article/details/47751181

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!