码迷,mamicode.com
首页 > 其他好文 > 详细

NBUT 1220 SPY

时间:2015-08-18 21:28:24      阅读:234      评论:0      收藏:0      [点我收藏+]

标签:字符串

  • [1220] SPY

  • 时间限制: 1000 ms 内存限制: 131072 K
  • 问题描述
  • The National Intelligence Council of X Nation receives a piece of credible information that Nation Y will send spies to steal Nation X’sconfidential paper. So the commander of The National Intelligence Council take measures immediately, he will investigate people who will come into NationX. At the same time, there are two List in the Commander’s hand, one is full of spies that Nation Y will send to Nation X, and the other one is full of spies that Nation X has sent to Nation Y before. There may be some overlaps of the two list. Because the spy may act two roles at the same time, which means that he may be the one that is sent from Nation X to Nation Y, we just call this type a “dual-spy”. So Nation Y may send “dual_spy” back to Nation X, and it is obvious now that it is good for Nation X, because “dual_spy” may bring back NationY’s confidential paper without worrying to be detention by NationY’s frontier So the commander decides to seize those that are sent by NationY, and let the ordinary people and the “dual_spy” in at the same time .So can you decide a list that should be caught by the Commander?

    A:the list contains that will come to the NationX’s frontier.

    B:the list contains spies that will be sent by Nation Y.

    C:the list contains spies that were sent to NationY before.

  • 输入
  • There are several test cases.
    Each test case contains four parts, the first part contains 3 positive integers A, B, C, and A is the number which will come into the frontier. B is the number that will be sent by Nation Y, and C is the number that NationX has sent to NationY before.
    The second part contains A strings, the name list of that will come into the frontier.
    The second part contains B strings, the name list of that are sent by NationY.
    The second part contains C strings, the name list of the “dual_spy”.
    There will be a blank line after each test case.
    There won’t be any repetitive names in a single list, if repetitive names appear in two lists, they mean the same people.
  • 输出
  • Output the list that the commander should caught (in the appearance order of the lists B).if no one should be caught, then , you should output “No enemy spy”.
  • 样例输入
  • 8 4 3
    Zhao Qian Sun Li Zhou Wu Zheng Wang
    Zhao Qian Sun Li
    Zhao Zhou Zheng
    2 2 2
    Zhao Qian
    Zhao Qian
    Zhao Qian
    
  • 样例输出
  • Qian Sun Li
    No enemy spy
  • 提示
  • 来源
  • 辽宁省赛2010

    题目意思有点难懂,看了两遍才理解,是说a国家得到情报说b国家要派间谍过来a国家,现在要捕抓‘真正的间谍’。此题为多组输入,输入数据有四行:第一行是三个整数A,B,C;第二行输入A个字符串,表示即将进入a国家的人名单;第三行输入B个字符串,表示b国家派出的间谍名单(其中可能有一些不是真正的间谍——即a国家在此之前已经派到b国家的间谍);第四行输入C个字符串,表示a国家在此之前已经派到b国家的间谍名单。要求在同一行输出所有的需要捕抓的真正的间谍名单,每个人名中间有一个空格(注意:末尾不能有空格,这题最坑的就是格式控制了,我PE了好几次才过)。如果A串中不存在真正的间谍,则输出“No enemy spy”。

    #include <algorithm>
    #include <iostream>
    #include <cstring>
    #include <cstdio>
    using namespace std;
    const int mx = 1e3 + 5;
    
    int a,b,c;
    char pe[mx][20],spy[mx][20],dpy[mx][20];
    
    int main() {
        while(~scanf("%d%d%d",&a,&b,&c)) {
            for(int i=0; i<a; i++) {
                scanf("%s",pe[i]);
            }
            for(int i=0; i<b; i++) {
                scanf("%s",spy[i]);
            }
            for(int i=0; i<c; i++) {
                scanf("%s",dpy[i]);
                for(int j=0; j<a; j++)
                    if(strcmp(dpy[i],pe[j])==0) {
                        strcpy(pe[j],"***");
    //                    printf("[%d,%d]     ",i,j);
                        break;
                    }
            }
            int cnt=0;
            for(int i=0; i<b; i++) {
                for(int j=0; j<a; j++)
                    if(strcmp(spy[i],pe[j])==0) {
                        cnt++;
                        if(cnt==1)
                            printf("%s",spy[i]);
                        else
                            printf(" %s",spy[i]);
    
                        continue;
                    }
    
            }
            if(!cnt)
                printf("No enemy spy");
            puts("");
    //        for(int i=0; i<a; i++)
    //            puts(pe[i]);
        }
        return 0;
    }
    


    好忧伤,PE了这么多次。。。

版权声明:本文为博主原创文章,未经博主允许不得转载。

NBUT 1220 SPY

标签:字符串

原文地址:http://blog.csdn.net/zhang_xueping/article/details/47756953

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!