码迷,mamicode.com
首页 > 其他好文 > 详细

Poj 1321 棋盘问题

时间:2015-08-18 22:48:18      阅读:150      评论:0      收藏:0      [点我收藏+]

标签:dfs

click here ~~

Input

输入含有多组测试数据。 
每组数据的第一行是两个正整数,n k,用一个空格隔开,表示了将在一个n*n的矩阵内描述棋盘,以及摆放棋子的数目。 n <= 8 , k <= n 
当为-1 -1时表示输入结束。 
随后的n行描述了棋盘的形状:每行有n个字符,其中 # 表示棋盘区域, . 表示空白区域(数据保证不出现多余的空白行或者空白列)。 


Output

对于每一组数据,给出一行输出,输出摆放的方案数目C (数据保证C<2^31)。

Sample Input
2 1
#.
.#
4 4
...#
..#.
.#..
#...
-1 -1


Sample Output
2
1

题目大意:这是中文题。。。应该能懂哈。。。。
解题思路:激素简单的dfs 搜索:
这个不太好说,具体上代码吧:

#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;
const int maxn = 10;
int n,k,cnt;
bool fac[maxn];
char map[maxn][maxn];

void dfs(int r, int num)
{
    if(num == k)
    {
        cnt++;
        return ;
    }
    if(r > n)
        return ;
    for(int i=1; i <= n; i ++)
    {
        if(!fac[i] && map[r][i] == ‘#‘)
        {
            fac[i] = 1;
            dfs(r+1, num+1);
            fac[i] = 0;
        }
    }
    dfs(r+1,num);
}
int main()
{
    while(cin>>n>>k)
    {
        if(n==-1 && k==-1)
            break;
        memset(fac, 0, sizeof(fac));
        for(int i = 1; i<= n; i++)
            for(int j = 1; j <= n; j++)
                cin>>map[i][j];
        cnt = 0;
        dfs(1,0);
        cout<<cnt<<endl;
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

Poj 1321 棋盘问题

标签:dfs

原文地址:http://blog.csdn.net/qingshui23/article/details/47760765

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!