码迷,mamicode.com
首页 > 其他好文 > 详细

2015 HUAS Summer Trainning #6~I

时间:2015-08-19 09:23:50      阅读:106      评论:0      收藏:0      [点我收藏+]

标签:

Description

The Sky is Sprite. 
The Birds is Fly in the Sky. 
The Wind is Wonderful. 
Blew Throw the Trees 
Trees are Shaking, Leaves are Falling. 
Lovers Walk passing, and so are You. 
................................Write in English class by yifenfei 

技术分享

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem! 
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead. 
 

Input

The input contains multiple test cases. 
Each case two nonnegative integer a,b (0<a, b<=2^31) 
 

Output

output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead. 
 

Sample Input

77 51 10 44 34 79
 

Sample Output

2 -3 sorry 7 -3
 
 解题思路:这个问题我本来是用公式将y求出来然后看它是不是整数,虽然答案对了,但是提交总是超时。所以看了书上的扩展欧几里德算法之后才有了一点眉目。
程序代码:
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
long long gcd(long long a,long long b,long long &x,long long &y)
{

    if(b==0)  {
        x=1;y=0;
        return a;
    }
    else{
    long long d=gcd(b,a%b,x,y);
    long long temp=x;
    x=y;
    y=temp-a/b*y;
    return d;
    }

}
int main()
{

    long long x,y,a,b;
    while(cin>>a>>b)
    {
        long long ans=gcd(a,b,x,y);
        if(1%ans)
            printf("sorry\n");
        else{
            while(x<0)
                x+=b,y-=a;
            printf("%d %d\n",x,y);
        }


    }
    return 0;
}

2015 HUAS Summer Trainning #6~I

标签:

原文地址:http://www.cnblogs.com/chenchunhui/p/4741194.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!