码迷,mamicode.com
首页 > 其他好文 > 详细

poj2253 最小生成树中的最大边 prim

时间:2015-08-19 09:27:42      阅读:123      评论:0      收藏:0      [点我收藏+]

标签:

Frogger
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 30620   Accepted: 9875

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists‘ sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona‘s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog‘s jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy‘s stone, Fiona‘s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy‘s and Fiona‘s stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy‘s stone, stone #2 is Fiona‘s stone, the other n-2 stones are unoccupied. There‘s a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

Source

 //题意要去将所有的石头都连起来,求最大边

Ulm Local 1997
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define INF 100000000.0

using namespace std;

struct node
{
    int x,y;
} point[300];

double chuli(node p1,node p2)
{
    return pow((p1.x-p2.x)*(p1.x-p2.x)+(p1.y-p2.y)*(p1.y-p2.y),1.0/2);
}
double Map[1200][1200];
double a[2000];
double low[2000];
int next[2000];
int n;
int Prim(int u0)
{
    int i,j;
    for(i=0; i<n; i++)
    {
        low[i]=Map[u0][i];
        next[i]=u0;
    }
    next[u0]=-1;
    double max=0.0;
    for(i=0; i<n-1; i++)
    {

        double min=INF;
        int v=-1;
        for(j=0; j<n; j++)
        {
            if(next[j]!=-1&&low[j]<min)
            {
                min=low[j];
                v=j;
            }
        }

        if(min>max)
            max=min;      //本体的核心
        if(a[v]<0.0000001)             //
        {
            a[v]=max;
            if(v==1)
                break;
        }

        if(v!=-1)
        {
            next[v]=-1;
            for(j=0; j<n; j++)
            {
                if(next[j]!=-1 &&Map[v][j]<low[j])
                {
                    low[j]=Map[v][j];
                    next[j]=v;
                }
            }
        }
    }
    printf("Frog Distance = %.3f\n",a[1]);  //poj不支持 %lf
}

int main()
{
	int Case=1;
    while(~scanf("%d",&n))
    {
    	if(n==0)
			break;
        for(int i=0; i<n; i++)
        {
            scanf("%d%d",&point[i].x,&point[i].y);
        }
        for(int i=0; i<n; i++)
            a[i]=0.0;
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
            {
                Map[i][j]=chuli(point[i],point[j]);
            }
		printf("Scenario #%d\n",Case++);
        Prim(0);
        printf("\n");
        //cout<<"*";
    }

}

版权声明:本文为博主原创文章,未经博主允许不得转载。

poj2253 最小生成树中的最大边 prim

标签:

原文地址:http://blog.csdn.net/became_a_wolf/article/details/47775439

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!