码迷,mamicode.com
首页 > 其他好文 > 详细

集训第六周 E题

时间:2015-08-19 11:04:45      阅读:211      评论:0      收藏:0      [点我收藏+]

标签:

E - 期望(经典问题)
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
Submit Status

Description

Given a dice with n sides, you have to find the expected number of times you have to throw that dice to see all its faces at least once. Assume that the dice is fair, that means when you throw the dice, the probability of occurring any face is equal.

For example, for a fair two sided coin, the result is 3. Because when you first throw the coin, you will definitely see a new face. If you throw the coin again, the chance of getting the opposite side is 0.5, and the chance of getting the same side is 0.5. So, the result is

1 + (1 + 0.5 * (1 + 0.5 * ...))

= 2 + 0.5 + 0.52 + 0.53 + ...

= 2 + 1 = 3

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 105).

Output

For each case, print the case number and the expected number of times you have to throw the dice to see all its faces at least once. Errors less than10-6 will be ignored.

Sample Input

5

1

2

3

6

100

Sample Output

Case 1: 1

Case 2: 3

Case 3: 5.5

Case 4: 14.7

Case 5: 518.7377517640

 

一个骰子,求每个面至少翻到一次的期望值

每个面翻到一次的期望值是n/(n-i)

 

技术分享
#include<iostream>
#include<cstdio>
using namespace std;

int main()
{
    int i,j,T,ca=0;
    cin>>T;
    while(T--)
    {
        int n;
        cin>>n;
        double ans=0;
        for(i=0;i<=n-1;i++)
            ans+=n*1.0/(n-i);
        printf("Case %d: %.10f\n",++ca,ans);
    }
     return 0;
}
View Code

 

集训第六周 E题

标签:

原文地址:http://www.cnblogs.com/zsyacm666666/p/4741386.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!