码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1273

时间:2015-08-19 13:29:57      阅读:78      评论:0      收藏:0      [点我收藏+]

标签:最大流   edmondkarp   acm   poj   


Drainage Ditches
Time Limit: 1000MS   Memory Limit: 10000KB   64bit IO Format: %I64d & %I64u


Every time it rains on Farmer John‘s fields, a pond forms over Bessie‘s favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie‘s clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

Hint

Source



求最大流:Edmonds-Karp算法
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
using namespace std;
#define maxn 200 + 5
#define inf 0x7fffffff
int m, n;
int c[maxn][maxn],pre[maxn];
int Edmonds_Karp(int s,int t)
{
  int minflow,maxflow = 0;
  while(1)
  {
  minflow = inf;
  memset(pre, 0 , sizeof(pre));
  queue <int> q;
  q.push(s);
  while(!q.empty())    //BFS找增广路
  {
    int x = q.front();
    q.pop();
    if(x == t) break;
    for(int i = 1;i <= n;i ++)
	{
	  if(c[x][i] > 0&& pre[i] == 0)
	  {
	    pre[i] = x;   //记录前驱
	    q.push(i);
	  }
	}
  }
  if(pre[t] == 0)  break;  //终点无前驱,即没有增广路
  for(int i = t; i != s;i = pre[i])
  minflow = min(minflow, c[pre[i]][i]);
  for(int i = t; i != s;i = pre[i])
  {
   c[pre[i]][i] -= minflow;
   c[i][pre[i]] += minflow;
  }
  maxflow += minflow;
  }
  return maxflow;
}
int main()
{
	int from,to,cc;
	while(scanf("%d%d", &m, &n) != EOF)
	{
	  memset(c, 0, sizeof(c));
	  while(m --)
	  {
	    scanf("%d%d%d", &from, &to, &cc);
	    c[from][to] += cc;  //可能有多条路径
      }
	  int ans = Edmonds_Karp(1,n);
	  printf("%d\n", ans);
	}
	return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ 1273

标签:最大流   edmondkarp   acm   poj   

原文地址:http://blog.csdn.net/mowenwen_/article/details/47778149

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!