码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1242 Rescue(BFS)

时间:2015-08-19 13:30:00      阅读:120      评论:0      收藏:0      [点我收藏+]

标签:hdu1242   hdu 1242   bfs   

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21701    Accepted Submission(s): 7745


Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel‘s friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there‘s a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel‘s friend. 

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 
 

Sample Input
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
13
 

Author
CHEN, Xue
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:  1240 1010 1072 1253 1372 
 

Statistic | Submit | Discuss | Note

也可以用DFS做 在这里用的BFS

#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
struct node
{
	int cost,x,y;
	friend bool operator<(node a,node b)
	{
		return a.cost>b.cost;
	}
};
int dir[4][2]={0,1,0,-1,1,0,-1,0};
char map[205][205];
int vis[205][205],n,m;
bool limit(int x,int y)
{
	if(map[x][y]!='#'&&x>=0&&x<n&&y>=0&&y<m)
	return true;
	else
	return false;
}
int tonum(int x,int y)
{
	if(map[x][y]=='x')
	return 2;
	else
	return 1;
}
void bfs(int x,int y)
{
	priority_queue<node>s;
	node temp,temp1;
	int flag=0;
	temp.x=x,temp.y=y,temp.cost=0;
	s.push(temp);
	while(!s.empty())
	{
		temp1=temp=s.top();
		s.pop();
		if(map[temp.x][temp.y]=='a')
		{
			flag=1;
			break;
		}
		for(int i=0;i<4;i++)
		{
			temp.x=temp.x+dir[i][0];
			temp.y=temp.y+dir[i][1];
			if(!vis[temp.x][temp.y]&&limit(temp.x,temp.y))
			{
				vis[temp.x][temp.y]=1;
				temp.cost+=tonum(temp.x,temp.y);
				s.push(temp);
			}
			temp=temp1;
		}
	}
	if(flag)
	printf("%d\n",temp.cost);
	else
	printf("Poor ANGEL has to stay in the prison all his life.\n");
	while(!s.empty())
	s.pop();
}
int main()
{
	int st_x,st_y;
	while(scanf("%d %d",&n,&m)!=EOF)
	{
		for(int i=0;i<n;i++)
		scanf("%s",map[i]);
		for(int i=0;i<n;i++)
		for(int j=0;j<m;j++)
		{
			if(map[i][j]=='r')
			{
				st_x=i,st_y=j;
				break;
			}
		}
		memset(vis,0,sizeof(vis));
		vis[st_x][st_y]=1;
		bfs(st_x,st_y);
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu1242 Rescue(BFS)

标签:hdu1242   hdu 1242   bfs   

原文地址:http://blog.csdn.net/su20145104009/article/details/47778109

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!