码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 3471 Most Powerful(状压DP)

时间:2015-08-19 13:37:32      阅读:113      评论:0      收藏:0      [点我收藏+]

标签:

链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3471

Most Powerful

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Recently, researchers on Mars have discovered N powerful atoms. All of them are different. These atoms have some properties. When two of these atoms collide, one of them disappears and a lot of power is produced. Researchers know the way every two atoms perform when collided and the power every two atoms can produce.

You are to write a program to make it most powerful, which means that the sum of power produced during all the collides is maximal.

Input

There are multiple cases. The first line of each case has an integer N (2 <= N <= 10), which means there are N atoms: A1, A2, ... , AN. Then N lines follow. There are N integers in each line. The j-th integer on the i-th line is the power produced when Ai and Aj collide with Aj gone. All integers are positive and not larger than 10000.

The last case is followed by a 0 in one line.

There will be no more than 500 cases including no more than 50 large cases that N is 10.

Output

Output the maximal power these N atoms can produce in a line for each case.

Sample Input

2
0 4
1 0
3
0 20 1
12 0 1
1 10 0
0

Sample Output

4
22


题意:两个原子弹碰到一起后会产生一定的能量,并且其中一个会消失,问你最多产生多少能量。

思路:状压dp,dp[S]表示在S状态下能够产生的最多的能量。


<span style="font-size:18px;">#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const int maxn=1<<11;
int dp[1<<12];
int power[12][12];
int main()
{
    int n;
    while(scanf("%d",&n) && n)
    {
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
           for(int j=0;j<n;j++)
            scanf("%d",&power[i][j]);
        for(int s=(1<<n)-1;s>=0;s--)
        {
            for(int i=0;i<n;i++)
            {
                if(s & (1<<i))//找到第i个不为零的位置,和第j个为零的位置合并,且由上个状态转移过来
                {
                    for(int j=0;j<n;j++)
                    {
                         if(i==j) continue;
                         else if(s & (1<<j)) continue;
                         dp[s]=max(dp[s],dp[(s|(1<<j))]+power[i][j]);
                    }
                }
            }
        }
        int ans=-1;
        for(int i=0;i<=(1<<n)-1;i++)
        {
            ans=max(ans,dp[i]);
        }
        printf("%d\n",ans);
    }
    return 0;
}
</span>



版权声明:本文为博主原创文章,转载记得著名出处,谢谢!

ZOJ 3471 Most Powerful(状压DP)

标签:

原文地址:http://blog.csdn.net/hellohelloc/article/details/47777431

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!