码迷,mamicode.com
首页 > 其他好文 > 详细

ACM学习历程—HDU1028 Ignatius and the Princess III(递推 || 母函数)

时间:2015-08-19 19:36:59      阅读:93      评论:0      收藏:0      [点我收藏+]

标签:

Description

"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input

4
10
20
 

Sample Output

5
42
627

 

这是一个整数划分,母函数是构造了一个多项式的乘法,然后指数为n的一项的系数就是划分数。效率是n*n*n。

递推稍微快一点,采用二位递推,p[i][j]表示i可以划分成j个数的划分个数。那么n的划分数就是sum(p[n][i])。

对于p[i][j]:

考虑最小的数,如果最小的数是1,就不再考虑这个1,那么就是p[i-1][j-1]。

如果最小数不是1,那么可以对每个数都减一,那么就是p[i-j][j]。

所以 p[i][j] = p[i-1][j-1]+(i-j >= 0 ? p[i-j][j] : 0);

 

代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <set>
#include <map>
#include <queue>
#include <string>
#include <algorithm>
#define LL long long

using namespace std;

int n, p[125][125];

void work()
{
    memset(p, 0, sizeof(p));
    p[1][1] = 1;
    for (int i = 2; i <= n; ++i)
        for (int j = 1; j <= n; ++j)
            p[i][j] = p[i-1][j-1]+(i-j >= 0 ? p[i-j][j] : 0);
    LL ans = 0;
    for (int i = 1; i <= n; ++i)
        ans += p[n][i];
    printf("%I64d\n", ans);
}

int main()
{
    //freopen("test.in", "r", stdin);
    while (scanf("%d", &n) != EOF)
        work();
    return 0;
}

 

ACM学习历程—HDU1028 Ignatius and the Princess III(递推 || 母函数)

标签:

原文地址:http://www.cnblogs.com/andyqsmart/p/4742660.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!