码迷,mamicode.com
首页 > 其他好文 > 详细

LA 3644 X-Plosives (并查集)

时间:2015-08-19 20:06:48      阅读:223      评论:0      收藏:0      [点我收藏+]

标签:

A secret service developed a new kind of explosive that attain its volatile property only when a speci c
association of products occurs. Each product is a mix of two different simple compounds, to which we
call a binding pair. If N > 2, then mixing N different binding pairs containing N simple compounds
creates a powerful explosive. For example, the binding pairs A+B, B+C, A+C (three pairs, three
compounds) result in an explosive, while A+B, B+C, A+D (three pairs, four compounds) does not.
You are not a secret agent but only a guy in a delivery agency with one dangerous problem: receive
binding pairs in sequential order and place them in a cargo ship. However, you must avoid placing in
the same room an explosive association. So, after placing a set of pairs, if you receive one pair that
might produce an explosion with some of the pairs already in stock, you must refuse it, otherwise, you
must accept it.
An example. Lets assume you receive the following sequence: A+B, G+B, D+F, A+E, E+G,
F+H. You would accept the rst four pairs but then refuse E+G since it would be possible to make the
following explosive with the previous pairs: A+B, G+B, A+E, E+G (4 pairs with 4 simple compounds).
Finally, you would accept the last pair, F+H.
Compute the number of refusals given a sequence of binding pairs.
Input
The input will contain several test cases, each of them as described below. Consecutive
test cases are separated by a single blank line.
Instead of letters we will use integers to represent compounds. The input contains several lines.
Each line (except the last) consists of two integers (each integer lies between 0 and 105) separated by
a single space, representing a binding pair.
Each test case ends in a line with the number `-1‘. You may assume that no repeated binding pairs
appears in the input.
Output
For each test case, the output must follow the description below.
A single line with the number of refusals.
Sample Input
1 2
3 4
3 5
3 1
2 3
4 1
2 6
6 5
-1
Sample Output
3

题目大意:

  有有限个化学物品,也就是A+B,如果输入的过程中存在环,那么就会爆炸,求加入车中的那些化学品中,形成爆炸的危险品有多少个?

解题思路:

  简单的并查集,并且用到了启发式合并,很容易判断,如果两者的祖先相同,那么就把他拒绝掉。

 

# include<cstdio>
# include<iostream>

using namespace std;

# define MAX 100004

int f[MAX],Rank[MAX];

void init()
{
    for ( int i = 0;i <= MAX;i++ )
    {
        f[i] = i;
        Rank[i] = i;
    }
}

int getf ( int x )
{
    if ( f[x]==x )
        return x;
    else
    {
        int t = getf(f[x]);
        f[x] = t;
        return f[x];
    }
}

void Union( int x,int y )
{
    int u = getf(x);
    int v = getf(y);
    if ( Rank[u] < Rank[v] )
    {
        f[u] = v;
    }
    else
    {
        if ( Rank[u]==Rank[v] )
            Rank[u]++;
        f[v] = u;
    }
}

int same ( int x,int y )
{
    return getf(x)==getf(y);
}

int main(void)
{
    int a,b;
    while ( scanf("%d",&a)!=EOF )
    {
        int ans = 0;
        init();
        while ( a!=-1 )
        {
            scanf("%d",&b);
            if ( same(a,b) )
            {
                ans++;
            }
            else
            {
                Union(a,b);
            }
            scanf("%d",&a);
        }
        printf("%d\n",ans);
    }


    return 0;
}

 

LA 3644 X-Plosives (并查集)

标签:

原文地址:http://www.cnblogs.com/wikioibai/p/4742790.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!