码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1745 Divisibility 【DP】

时间:2015-08-19 20:23:13      阅读:140      评论:0      收藏:0      [点我收藏+]

标签:

Divisibility
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 11044   Accepted: 3949

Description

Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are eight possible expressions: 17 + 5 + -21 + 15 = 16 
17 + 5 + -21 - 15 = -14 
17 + 5 - -21 + 15 = 58 
17 + 5 - -21 - 15 = 28 
17 - 5 + -21 + 15 = 6 
17 - 5 + -21 - 15 = -24 
17 - 5 - -21 + 15 = 48 
17 - 5 - -21 - 15 = 18 
We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible by 5. 

You are to write a program that will determine divisibility of sequence of integers. 

Input

The first line of the input file contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space. 
The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it‘s absolute value. 

Output

Write to the output file the word "Divisible" if given sequence of integers is divisible by K or "Not divisible" if it‘s not.

Sample Input

4 7
17 5 -21 15

Sample Output

Divisible




题意:给你N个数和一个数K,问你能不能 按顺序在两个数间添加一个运算符使得N个数的结果mod K = 0。(运算符只能是加减)



思路:设dp[i][j]表示前i个数经过加减后 结果mod K = j是成立的,那么我们只要推出dp[N][0]是否为1就ok了。


状态转移方程

当dp[i-1][j]非0时

1,dp[i][t] = 1其中t = ((j + a[i]) % K + K) % K. 说明一下——(j + a[i])%K后 加个K最后再取余 是为了避免值是负数。

2,dp[i][t] = 1其中t = ((j - a[i]) % K + K) % K.


AC代码:


#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXN 10000+10
using namespace std;
int dp[MAXN][110];//表示前i个数经过加减运算后 结果mod K = j 是成立的
int a[MAXN];
int main()
{
    int N, K;
    while(scanf("%d%d", &N, &K) != EOF)
    {
        for(int i = 1; i <= N; i++)
            scanf("%d", &a[i]);
        memset(dp, 0, sizeof(dp));//初始化
        dp[0][0] = 1;//初值
        for(int i = 1; i <= N; i++)
        {
            for(int j = 0; j < K; j++)
            {
                if(dp[i-1][j])
                {
                    //注意j+a[i] 或者 j-a[i]可能是负数 需要加K处理
                    int t = ((j + a[i]) % K + K) % K;
                    dp[i][t] = 1;
                    t = ((j - a[i]) % K + K) % K;
                    dp[i][t] = 1;
                }
            }
        }
        if(dp[N][0])
            printf("Divisible\n");
        else
            printf("Not divisible\n");
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

poj 1745 Divisibility 【DP】

标签:

原文地址:http://blog.csdn.net/chenzhenyu123456/article/details/47785195

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!