码迷,mamicode.com
首页 > 其他好文 > 详细

poj1159(dp)

时间:2015-08-19 20:26:16      阅读:135      评论:0      收藏:0      [点我收藏+]

标签:

题目链接:http://poj.org/problem?id=1159

 

Palindrome
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 56628   Accepted: 19577

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from ‘A‘ to ‘Z‘, lowercase letters from ‘a‘ to ‘z‘ and digits from ‘0‘ to ‘9‘. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

Source

 

 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
#define ll long long
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;

int n;
short int dp[5005][5005];
char str[5005];

int main ()
{
    cin>>n;
    cin>>str;
    memset(dp, 0, sizeof(dp));
    for (int i=1; i<n; i++)
    {
        for (int j=i-1; j>=0; j--)
        {
            if (str[i] != str[j])
                dp[i][j] = min(dp[i-1][j], dp[i][j+1])+1;
            else
                dp[i][j] = dp[i-1][j+1];
        }
    }
    cout<<dp[n-1][0]<<endl;
    return 0;
}


 

版权声明:本文为博主原创文章,未经博主允许不得转载。

poj1159(dp)

标签:

原文地址:http://blog.csdn.net/d_x_d/article/details/47786391

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!