码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3267 The Cow Lexicon

时间:2014-07-12 21:25:28      阅读:250      评论:0      收藏:0      [点我收藏+]

标签:poj   acm   

The Cow Lexicon
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 7909   Accepted: 3711

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters ‘a‘..‘z‘. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range ‘a‘..‘z‘) of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively: W and L 
Line 2: L characters (followed by a newline, of course): the received message 
Lines 3..W+2: The cows‘ dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2

题意:如何删除最少的字母,能够使得字符串是下面列出来的字符串的连接。

动态规划,这里是从前往后的DP方程。


AC代码如下:



#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

int min(int a,int b)
{
    return a<b?a:b;
}

int main()
{
    int n,m;
    int i,j;
    char a[610],b[1005][1005];
    int dp[610];
    int la,lb;
    int x,y;
    while(cin>>n>>m)
    {
        cin>>a+1;
        for(i=0;i<n;i++)
            cin>>b[i]+1;
        dp[0]=0;
        for(i=1;i<=m;i++)
        {
            dp[i]=dp[i-1]+1;//如果无法匹配
            for(j=0;j<n;j++)
            {
                lb=strlen(b[j]+1);
                x=0;y=lb;
                if(i>=lb&&a[i]==b[j][lb])
                {
                    while(i-x>0)
                    {
                        if(a[i-x]==b[j][y])
                        {x++;y--;}
                        else x++;
                        if(!y)
                        {
                            dp[i]=min(dp[i],dp[i-x]+x-lb);
                            break;
                        }
                    }
                }

            }
        }
        cout<<dp[m]<<endl;
    }
    return 0;
}




POJ 3267 The Cow Lexicon,布布扣,bubuko.com

POJ 3267 The Cow Lexicon

标签:poj   acm   

原文地址:http://blog.csdn.net/hanhai768/article/details/37662795

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!