标签:hdu 1028 acm c++
Ignatius and the Princess III
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
Sample Output
给定n,n最多分成n份,有几种分法?重点是分析:(分析过程可参考博文)
f[i][j]表示把整数 i 拆成最多 j 个数字所具有的方法数。
那么if (i >j) f[i][j] = f[i-j][j] + f[i][j-1]; 意思就是如果i>j,那么有两种方式:一种是先把i里面分理处j个1,然后再把i-j拆成最多i-j个数字;另一种是把i拆分成最多j-1个数字。
if (i < j) f[i][j] = f[i][i]; 意思就是如果i<j,那么这种情况和把数字i最多拆成i个数字的是一样的。
if (i == j) f[i][j] = f[i][j-1] + 1; 意思就是如果i==j,那么可以把数字i拆分成j-1个数字,也可以把数字i拆分成i个1(这个就是那个1的意义)
另外,当i==1||j==1时,f[i][j]=1。
代码如下:
#include <cstdio>
int main(){
int n;
while(scanf("%d",&n)==1){
int i,j,f[125][125]={0};
for(i=0;i<=n;i++)
f[i][1]=f[1][i]=1;
for(i=2;i<=n;i++)
for(j=1;j<=n;j++){
if(i>j) f[i][j]=f[i-j][j]+f[i][j-1];
else if(i==j) f[i][j]=1+f[i][j-1];
else f[i][j]=f[i][i];
}
printf("%d\n",f[n][n]);
}
return 0;
}
版权声明:本文为博主原创文章,未经博主允许不得转载。
HDU 1028.Ignatius and the Princess III【分析】【8月20】
标签:hdu 1028 acm c++
原文地址:http://blog.csdn.net/a995549572/article/details/47808885