码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1422:Air Raid(最大独立集)

时间:2014-07-12 21:04:44      阅读:232      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   strong   os   

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 6547   Accepted: 3896

Description

Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town‘s streets you can never reach the same intersection i.e. the town‘s streets form no cycles. 

With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper. 

Input

Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format: 

no_of_intersections 
no_of_streets 
S1 E1 
S2 E2 
...... 
Sno_of_streets Eno_of_streets 

The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town‘s streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk <= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections. 

There are no blank lines between consecutive sets of data. Input data are correct. 

Output

The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town. 

Sample Input

2
4
3
3 4
1 3
2 3
3
3
1 3
1 2
2 3

Sample Output

2
1

最小路径覆盖: 

用尽量少的不相交简单路径覆盖有向无环图G的所有结点。解决此类问题可以建立一个二分图模型。把所有顶点i拆成两个:X结点集中的i和Y结点集中的i‘,如果有边i->j,则在二分图中引入边i->j‘,设二分图最大匹配为m,则结果就是n-m。



#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>

using namespace std;

const int M = 1000 + 5;
int t, n, k;
int link[M];
bool MAP[M][M];
int cover[M];
int ans;

void init()
{
    int x, y;
    memset(MAP, false, sizeof(MAP));
    for(int i=1; i<=k; i++)
    {
        scanf("%d%d", &x, &y);
        MAP[x][y]=true;
    }
}

bool dfs(int x)
{
    for(int y=1; y<=n; y++)
    {
        if(MAP[x][y] && !cover[y])
        {
            cover[y]=true;
            if(!link[y] || dfs(link[y]))
            {
                link[y]=x;
                return true;
            }
        }
    }
    return false;
}

int main ()
{
    scanf("%d", &t);
    while( t-- )
    {
        scanf("%d%d", &n, &k);
        ans=0;
        init();
        memset(link, 0, sizeof(link));
        for(int i=1; i<=n; i++)
        {
            memset(cover, false, sizeof(cover));
            if( dfs(i) )
                ans++;
        }
        printf("%d\n", n-ans);
    }

    return 0;
}





POJ 1422:Air Raid(最大独立集),布布扣,bubuko.com

POJ 1422:Air Raid(最大独立集)

标签:des   style   http   color   strong   os   

原文地址:http://blog.csdn.net/u013487051/article/details/37659919

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!